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Introduction 
 

This user guide is an overview of the twelve types of transactions that can be used when generating files to be 

transferred to the financial institution.  In addition, information is also provided that includes how the application can 

be used, definitions of the menus and toolbar, the twelve ACH Standard Entry Classes and Tax Type Conversion 

Codes. 

 

This program provides businesses with the capacity to set up, perform and track ACH transactions all from the 

convenience of the office.  NACHA formatted files can be generated and maintained using this ACH program.  All 

files generated and maintained are formatted to be transferred to the financial institution in order to generate and 

process as an ACH file. 

 

ACH information is entered into columns, rows and cells, and a toolbar provides functions such as copying and 

pasting information from one cell to another. 

 

 

ACH Screen 
 

 

Toolbar 

Menus 

Transaction Information 

File Totals 
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Getting Started 
 

� 1. Log in to Red Mountain Bank’s Business Online Banking and select "Premier ACH" from the Funds 

Management menu. 
 

 

� 2. A warning page is displayed.  Click the "Install" button. 
 

 
 

 

� 3. The File Download box is displayed.  Click "Open". 
 
 

� 4. The Welcome to the InstallShield Wizard box is displayed.  Click "Next". 
 

 

� 5. The Setup Type box is displayed.  Select the "Complete" radio button, and click "Next". 
 

 

� 6. The Ready to Install the Program box is displayed.  Click "Install". 
 

 

� 7. The InstallShield Wizard Completed box is displayed.  Click "Finish". 
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� 8. The warning page is again displayed.  Click "Start" to open Premier ACH. 
 

 
 

 

� 9. Premier ACH is displayed.  From the View menu of Premier ACH, select "Show Default NACHA Specs". 
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� 10. The Default NACHA Specs box is displayed.  Establish the following values and click "Save As Default": 

 

Immediate Destination 061000146  (this is the Atlanta Fed RT #) 

Immediate Origin 062206486 (Red Mountain Bank’s RT #) 

Company Name Your Company Name 

Company Identification Your Tax Id Number 

Company Entry Description Payroll or Monthly Dues, etc. (This Description will show to 

Receiver) 

Originating DFI Identification 06220648 (Red Mountain Bank’s RT# minus the last digit) 

 

Immediate Destination Name, Immediate Origin Name, and Reference Code are optional and do not require 

values for Premier ACH to function properly. 
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Operational Hints 

 

 

File Name Extensions 
 

Files generated in Premier ACH are initially saved locally with the .wrk extension.  This unique extension 

differentiates "working" files from NACHA-formatted files, which use the .ach extension.  After entering data 

into ACH working files, corporate clients need to save ACH working files as NACHA-formatted files.  The 

NACHA-formatted files are uploaded to the financial institution for processing.  Any changes to ACH files 

must first be made to working (.wrk) files.  After all required changes are implemented, save files to the 

NACHA format (.ach). 
 

NACHA-formatted files are generated by selecting "Save As" and "NACHA File" from the File menu. 
 

 

 

Opening non-Premier ACH Files 
 

 

 

Third-party ACH Software Customers 

 

ACH files generated by a third-party ACH origination program can be opened in Premier ACH without utilizing 

the import process by simply changing the file extension to ".ach". 
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Generating an ACH File 
 

To generate an ACH file, open the program by clicking the link from the Fund Management menu of the account 

page.  The ACH workspace displays in the account page.  From the File menu, select "New".  Enter information in the 

cells that are applicable to the type of ACH transaction file being generated. 

 

 
 

Twelve types of ACH transactions can be initiated through the File menu: 

 

Cash Concentration or Disbursement (CCD) 

Cash Concentration or Disbursement + TXP (Federal) 

Cash Concentration or Disbursement + TXP (State) 

Consumer Cross-Border Payment (PBR) 

Corporate Cross-Border Payment (CBR) 

Corporate Trade Exchange (CTX) 

Customer-Initiated Entry (CIE) 

Internet-Initiated Entry (WEB) 

Point-of-Purchase Entry (POP) 

Prearranged Payment or Deposit Entry (PPD) 

Re-presented Check Entry (RCK) 

Telephone-Initiated Entry (TEL) 
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Generating a NACHA File 

 

NACHA Standard Files can be generated using the ACH program.  Selecting "New" from the File menu establishes a 

"working file" (i.e. a file that has not been fully completed yet) format, which can be saved as a partial file.  When the 

file is completed, select "Save As" and "NACHA File" from the File menu, and the NACHA Header Specification 

field is displayed.  If errors are found in the file, a message box is displayed indicating the specific error.  Necessary 

changes can then be made prior to saving the file.  A Save dialog box is displayed so the file can be saved under a 

name other than the working file name.  Once completed, the file is saved in a standard NACHA format. 

 

Importing an ACH File 
 

Select "Import" from the File menu to import an ACH formatted file generated from another source (e.g. a payroll 

package). 

 

 
 

 

Import File Step 1 of 4 

 

The first step is to select a file that has already been established from the Select a File to Import box and click 

"Open". 

 
Note: Any NACHA formatted ACH File can be opened from the "Open" option under the File menu. 
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Import File Step 2 of 4 

 

To use an existing template, select "Existing Template" and browse for its location.  To generate a new template, 

select "New Template".  Next, choose the "Entry Class Code" from the drop-down menu and select whether the data 

in the file is "Delimited" or "Fixed Width".  Click the "Next" button. 

 

 
 

Import File Step 3 of 4 (Delimited) 

 

The third step is to indicate what type of character is used as a delimiter in the file.  If the delimiting character is not a 

choice, enter the appropriate delimiter in the "Other" box and place a check for that selection.  The Layout Preview 

then displays lines where the delimiters lie within the file.  Click the "Next" button. 
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Import File Step 3 of 4 (Fixed Width) 

 

The third step is to establish columns for importing a fixed width file.  Click the mouse between each set of data to 

establish the columns.  Click the "Next" button. 

 

 
 

 

Import File Step 4 of 4 

 

The fourth step is to establish fields for each column in the file.  Highlight the column that requires a field assignment, 

and select the appropriate field from the drop-down menu.  Click the "Finish" button. 

 

A Do You Want to Save This Template box is displayed.  Click "Yes" to save current settings as a template or "No" 

to proceed without saving a template.  A template will enable corporate clients to import files with similar format 

without establishing the layout each time. 

 

Note: When establishing "Effective Entry Date", an additional drop-down menu displays.  Select the appropriate 

date format to ensure the date is imported properly. 
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ACH File Types 

 

For each of the following File Types, a requirement classification is provided at the end of each field description listed 

in this documentation.  The requirement classification definitions are taken from the National Automated Clearing 

House Association ACH Rule Book and are as follows: 

 

Mandatory – A "Mandatory" field is necessary to ensure the proper routing and/or posting of an ACH entry.  Any 

"Mandatory" field not included in an ACH record will cause that entry, batch, or file to be rejected by the ACH 

Operator.  A rejected entry will be returned to the ODFI by the ACH Operator.  A rejected batch or rejected file 

will be reported to the ODFI or Sending Point by the ACH Operator. 

 

Optional – The inclusion or omission of an "Optional" data field is at the discretion of the Originator and ODFI.  

However, if a DFI does originate files using optional data fields, these fields must be returned to the ODFI if the 

entry is returned. 
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Menu Bar and Toolbar 
 

The ACH program menu bar and toolbar organize commands to provide easy access to many functions such as 

opening a file, copying, pasting and printing. 

 

 

 

 
 

 

 

 
Select "New" to generate a new document from the list displayed. 

 

 

 
 

 

Click or select "Open" to open an existing ACH file. 

 

 
 

 

Click or select "Close" to close the current ACH file. 

 

 
Select "Import" to open a file generated from another source. 

 

 

 
 

 

Click or select "Save" to save changes made to the current ACH file. 

 

 

File Menu Tool Bar 
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Menu Bar and Toolbar – continued 
 

 
Select "Save As", and then click to select the appropriate "Save As" 

function.  The following choices are: 

 

Work File: saves the current file as a new "working 

file". 

 

Password Protected File: saves the file with password protection.  

The file can be saved as a "working 

file". 
 

NACHA File: saves the current file in a standard 

NACHA Format ready to be sent to the 

Financial Institution. 

 

  

  

 
 

 
 

Click or select "Print" to print the active ACH file to the printer specified 

on the computer. 

 

The print function defaults to print by batches.  Each batch is separated by 

batch count and amount totals.  If the file is sorted by anything but batch, 

the printout will look similar to a sorted file. 

 

 

 
Select "Exit" to close the ACH program. 
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Menu Bar and Toolbar – continued 
 
 

 
 

 

 

 
 

 
 

Click or select "Cut" to delete all highlighted text and transfer it to the Windows 

Clipboard. (The cut text is removed from the clipboard when it is overwritten by 

copying or cutting other text.) 

 
 

 
 

Select "Copy" to copy highlighted text to the clipboard. 

 

 

 
 

 
 

Select "Paste" to paste the contents of the clipboard into the cell where the cursor 

is positioned. 

 

 

 
 

 
 

Click or select "Delete" to delete a cell or a row.  When "Delete" is clicked or 

selected, a prompt displays an option to either delete a row or a cell. 

 

 
 

Select "Insert Row" from the Edit menu to insert a blank row in an ACH file.   

 

 

 
Select "Preferences" to establish the following: 

 

• Default Current Date 

• Display Confirmation On Save 

• Flood Fields From Previous Row 

• Split Screen 

 

  
 

 

Edit Menu  
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Menu Bar and Toolbar – continued 
 

 

 

 
 

 
Select "About PremierACH" to display version number of Premier ACH. 

 

 
Select "Show Default NACHA Specs" to display NACHA specifications 

that are required to be established before saving the file to NACHA format.  

The specifications required to be established are: 

 

• Immediate Destination 

• Immediate Origin 

• Company Name 

• Company Identification 

• Company Entry Description 

• Originating DFI Identification 

 

Optional specifications include: 

 

• Immediate Destination Name 

• Immediate Origin Name 

• Reference Code 

 

 

 
 

 
 

 

Select "Show Totals" or "Hide Totals" to display/hide ACH file 

information below the editor work area. 

 

 

View Menu 
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Shortcuts 
 

The following items are shortcuts to be used when working with ACH Files. 

 

 

Navigating Throughout A Cell Or Grid 

 

"Tab" Navigates cursor to the right. 

"Shift" + "Tab" Navigates cursor to the left. 

"Enter" Navigates cursor down. 

"Shift" + "Enter" Navigates cursor up. 

 

 

ACH File Totals 
 

ACH file totals are automatically maintained at the bottom of the screen keeping track of debits and credits for File 

Total, File Entry Count, Batch Total and Batch Entry Count. 
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ACH Participants 
 

The six participants in ACH transactions, as defined in the ACH Rule Book, are as follows: 

 

Originator 

 

The Originator is the entity that agrees to initiate ACH entries into the payment system according to an 

arrangement with a Receiver.  The Originator is usually a company directing a transfer of funds to or from a 

consumer's or another company's account.  In the case of the Customer-Initiated Entry, however, the originator 

can be an individual initiating the funds transfer activity to or from his or her own account.  The term "company" 

is intended to be representative of the Originator of electronic ACH entries and does not imply exclusion of other 

types of organizations. 

 

 

Receiving Depository Financial Institution (RDFI) 

 

The Receiving Depository Financial Institution (RDFI) is the DFI that receives ACH entries from the ACH 

Operator and posts them to the accounts of its depositors (receivers). 

 

 

Originating Depository Financial Institution (ODFI) 
 

The Originating Depository Financial Institution (ODFI) is the institution that receives the payment instructions 

from Originators and forwards the entries to the ACH Operator.  A Depository Financial Institution (DFI) can 

participate in the ACH as a Receiving Depository Financial Institution (RDFI) without being an ODFI; however, 

if a DFI chooses to originate ACH entries, it must also agree to act as an RDFI. 

 

 

Automated Clearing House (ACH) Operator 
 

An Automated Clearing House Operator is the central clearing facility, operated by a Federal Reserve Bank 

(FRB) or a private organization, which receives entries from ODFIs, distributes the entries to appropriate RDFIs, 

and performs the settlement functions for the financial institutions. 

 

 

Receiver 
 

A Receiver is a person or an organization that has authorized an Originator to initiate an ACH entry to the 

Receiver's account with the RDFI. 

 

 

NACHA 
 

The National Automated Clearing House Association provides operating guidelines to member ACH participants. 
 


